Notifications
Clear all

Empty log files  

  RSS

pitchfork
(@pitchfork)
Active Member
Joined: 3 months ago
Posts: 10
27/07/2020 4:11 am  

Hi All

Pure 2.0.8 installed on a QNAP backing up multiple VMs from an esxi server.

Just checked on our installation of Pure and we seem to have nothing in the logs. Have tried "Overall" as the time and "Any" as the other choices.

Nothing. Nada. Zip.

Backups appear to be correctly working.

Can anyone shine any light on this please?

Thanks and regards

Nigel.


Quote
Marijan Kozic
(@marijan)
Member Admin
Joined: 1 year ago
Posts: 58
27/07/2020 9:54 am  

Event logs are kept in an SQLite database file within the backup repository (PureLog.db) so the first thing would be to check if there is something wrong with that file. You should also check the main application logs (<Pure installation folder>/log) for clues as to why the Event log is not functioning.

You can also simply delete the log file and it will be regenerated on next Pure start.

You can find out the exact installation folder by searching for the 'nsd' process (e.g. 'ps aux | grep nsd').


ReplyQuote
pitchfork
(@pitchfork)
Active Member
Joined: 3 months ago
Posts: 10
28/07/2020 7:26 am  

@marijan Did exactly that. I also noticed in one of the job logs:

[27/Jul/2020:01:00:35][31413.7fc8a1ffb700][-nsproxy:reap-] Notice: starting
[27/Jul/2020:01:00:35][31510.7fb4c84a6700][-main-] Notice: OpenSSL 1.0.2q 20 Nov 2018 initialized
[27/Jul/2020:01:00:35][31413.7fc8ba500700][-main-] Error: file is not a database
file is not a database
while executing
"$db eval {PRAGMA quick_check(1)} res {
if {$res(quick_check) ne {ok}} {
$db close
file delete [my DbPath $sp]
retu..."
(procedure "CheckDb" line 21)
::nsf::__#1T ::Log->CheckDb
invoked from within
"$me CheckDb $sp"
(procedure "Boot" line 46)
::Log->Boot
invoked from within
"Log Boot"
("uplevel" body line 1)
invoked from within
"uplevel [list $cmd] [lrange $args 1 end]"
invoked from within
"Log Boot"
while executing callback
ns:tclcallback {
Log Boot
}
[27/Jul/2020:01:00:40][31413.7fc8a2ffd700][-tclthread-] Notice: Win10-VPN-HRK: already backed up in this BW. Skipping.
[27/Jul/2020:01:00:40][31413.7fc8a2ffd700][-tclthread-] Notice: WIN10-PROD-KXD: already backed up in this BW. Skipping.

Indeed, when I took a copy of the PureLog.db (last modified a few days ago) and tried to open it it appeared to be corrupted. DB Browser for SQLLite said "Could not open database file. Reason: File is not a database.

I have renamed the original file and run a manual backup. New PureLog.db was created and logging is working again.

Thanks

Nigel.

 


ReplyQuote
Share: